Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-10283

Audio doesnt work - System audio device does not start

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: Sound
    • Labels:
      None
    • Environment:

      Virtualbox 5.0.2 with AC97 audio

      Description

      Audio does not work in trunk for me for a while now. The software system audio device fails to start properly

      (../../ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\System32\drivers\sysaudio.sys at F65B5000 with f pages
      (../../ntoskrnl/io/iomgr/deviface.c:1408) IopGetDeviceObjectFromDeviceInstance failed to find status SW
      (../../ntoskrnl/io/iomgr/deviface.c:1408) IopGetDeviceObjectFromDeviceInstance failed to find status SW
      (../../ntoskrnl/io/iomgr/deviface.c:1408) IopGetDeviceObjectFromDeviceInstance failed to find status SW
      (../../ntoskrnl/io/iomgr/deviface.c:1408) IopGetDeviceObjectFromDeviceInstance failed to find status SW
      (../../ntoskrnl/io/pnpmgr/pnpmgr.c:469) \Driver\SYSAUDIO->AddDevice(SW\{a7c7a5b0-5af3-11d1-9ced-00a024bf0407}\{9b365890-165f-11d0-a195-0020afd156e4}) failed with status 0xc0000035

      Attempting to play audio shows Failed to open \\.\wdmaud

        Attachments

        1. debug.log
          81 kB
        2. mixerbug.jpg
          mixerbug.jpg
          21 kB
        3. r69411-audio.png
          r69411-audio.png
          598 kB
        4. r69425-audio.png
          r69425-audio.png
          49 kB
        5. r69425-boot.log
          43 kB

          Issue Links

            Activity

              People

              • Assignee:
                bug zilla Bug Zilla
                Reporter:
                karokidii kd-11
              • Votes:
                2 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated: