Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-11139

USB Input Not Working

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Untriaged
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      When I try to run ReactOS on my custom-built computer (ASRock 970 Extreme3 R2.0, latest BIOS), I can't use my USB mouse or my USB keyboard, though a PS/2 keyboard worked. I've tried another WIP operating system (Genode), and I found that it worked with devices in my USB 3.0 ports, but not my USB 2.0 ports. With ReactOS, I tried both, but neither showed any signs of working. Because the installer didn't work (possibly related?), I used VirtualBox to create a hard drive image, then converted it to a raw image and copied it over with dd. I used Qemu with the same image and a virtual USB keyboard and mouse, and it worked just fine. I've attached two logs, one from real hardware and one from Qemu with USB input. Note that I have been using the official 0.4.0 release, but the code that seems to be related hasn't been updated since that release anyway.

        Attachments

        1. debug.log
          52 kB
        2. qemulog
          30 kB

          Issue Links

            Activity

              People

              • Assignee:
                bug zilla Bug Zilla
                Reporter:
                nobody_iii Ben Larson
              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated: