Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-11290

Make sure the loader respects compatibility settings

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      We need to make sure the loader respects settings for version compatibility to load the appropriate DLLs

      Timo mentioned the option to include all functions in the exports by default, but patch out the non-allowed exports when loading under an older nt 'version'.

      This should be handled in ntdll, and could get information from f.e. an extra section in the binary.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                learn_more Mark Jansen
                Reporter:
                ThePhysicist Timo Kreuzer
              • Votes:
                3 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated: