Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-11338

unpartioned space of 977 KB causes problems

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Won't Fix
    • Fix Version/s: None
    • Component/s: Setup
    • Labels:
      None

      Description

      I try to install reactos on a system with an existing partition starting at sector 2048:

      Index  Start         Length        Hidden      Nr  Type  Boot  RW
      -----  ------------  ------------  ----------  --  ----  ----  --
          0          2048      20969472        2048   1     b     *   N
          1             0             0           0   0     0         N
          2             0             0           0   0     0         N
          3             0             0           0   0     0         N

      During setup an unpartioned space of 977 KB is shown. unpart1.png
      It is not possible to create a partition, because the size must be entered in MB, and it is less then 1 MB. A partition of 0 MB cannot be created.

      When I press enter on the unpartitioned space, an error message is shown that a reactos partition must be at least 450MB. unpart2.png

      Back in the partition window, the unpartitioned space is now shown as a new partition, which is drive C:. unpart3.png

      After selecting the 10 GB partition (now drive D:) to install reactos on, a dialog is shown how to format it. unpart4.png

      After choosing quick format, an error message is shown, and the computer has to be rebooted. unpart5.png

      After the reboot, the existing partition now uses slot 2 in the MBR:

      Index  Start         Length        Hidden      Nr  Type  Boot  RW
      -----  ------------  ------------  ----------  --  ----  ----  --
          0             0             0           0   0     0         N
          1          2048      20969472        2048   1     b     *   N
          2             0             0           0   0     0         N
          3             0             0           0   0     0         N

      This caused the problem I describe in CORE-11330

        Attachments

        1. boot1.log
          21 kB
        2. unpart1.png
          unpart1.png
          8 kB
        3. unpart2.png
          unpart2.png
          8 kB
        4. unpart3.png
          unpart3.png
          8 kB
        5. unpart4.png
          unpart4.png
          7 kB
        6. unpart5.png
          unpart5.png
          5 kB
        7. unpart6.png
          unpart6.png
          394 kB

          Issue Links

            Activity

              People

              • Assignee:
                bug zilla Bug Zilla
                Reporter:
                wimh wimh
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: