Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-11360

Inno Script Studio fails to start due to a problem with userenv

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: 0.4.2
    • Component/s: NTCore
    • Labels:
      None

      Description

      Inno Setup is a nice free software (BSD-style license) for creating windows installers

      http://www.jrsoftware.org/isdl.php
      (By the way, I report that Inno Setup does work fine in React OS !)

      Inno Script Studio is a GUI for creating scripts for Inno Setup. I have installed both programs,

      innosetup-5.5.9-unicode.exe

      ISStudio_Latest.exe version 2.2.2.32

      Inno Setup compiler seems to work fine, and also Inno Script Studio
      installs Ok but this second problem fails to start with the message

      "This application has failed to start because userenv was not found. Re-installing the application may fix the problem"

      Testing enviroment: r71504 compiled from the sources using GCC
      in ubuntu 14.04
      Test run in Virtualbox 5.0.20

      I`m submitting a full log, but the last lines when the problem happened are

      (win32ss/user/ntuser/winpos.c:3210) err: NtUserSetWindowPos bad window handle!
      fixme:(dll/win32/shell32/shlexec.cpp:1774) flags ignored: 0x00104000
      (sdk/lib/rtl/actctx.c:2355) unknown attr xmlns:asmv3=urn:schemas-microsoft-com:asm.v3
      (sdk/lib/rtl/actctx.c:2447) unknown element compatibility
      (sdk/lib/rtl/actctx.c:2447) unknown element asmv3:application
      err:(win32ss/user/user32/windows/window.c:470) CreateWindowExW RegisterSystemControls
      WARNING:  MmLockPageableDataSection at ntoskrnl/mm/ARM3/drvmgmt.c:62 is UNIMPLEMENTED!
      fixme:(win32ss/user/user32/misc/dllmain.c:362) ClientThreadSetup is UNIMPLEMENTED!
      WARNING:  MmUnlockPageableImageSection at ntoskrnl/mm/ARM3/drvmgmt.c:39 is UNIMPLEMENTED!
      (win32ss/user/ntuser/nonclient.c:1072) err: Wnd is active and not set active!

        Attachments

        1. Hello_mod.exe
          3 kB
          Vort
        2. Inno_Script_Studio_not_working.png
          45 kB
          pdenapo
        3. Inno_Script_Studio_not_working-win_userenv.png
          43 kB
          pdenapo
        4. Inno_Script_Studio.log
          63 kB
          pdenapo
        5. ReactOS_InnoSetup.png
          580 kB
          hbelusca

          Activity

            People

            • Assignee:
              hbelusca hbelusca
              Reporter:
              pdenapo pdenapo
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: