Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-13040

Bug in TransparentBlt with 32bpp bitmaps and alpha channel

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: 0.4.7
    • Component/s: Win32SS
    • Labels:
      None

      Description

      In windows when I call TransparentBltĀ  using a bitmap with alpha channel, it doesn't matter if the transparent color has the alpha value or not. In ros it needs the exact alpha value to work. I'm attaching a sample bitmap from the LunaInspirat theme that shows the problem. It is a 32bpp bitmap with an alhpa channel. In windows either 0x00FF00FF or 0xFFFF00FF work but in ros the transparency works only if I pass 0xFFFF00FF.
      I also attached a sample exe that does the TransparentBlt with 0x00FF00FF.
      test2.exe

        Attachments

        1. bitmap1.bmp
          bitmap1.bmp
          10 kB
        2. snapshot115.png
          snapshot115.png
          11 kB
        3. test2.exe
          114 kB
        4. trans-fixed.patch
          0.8 kB
        5. trans-fixed.png
          trans-fixed.png
          27 kB
        6. type-a.patch
          2 kB
        7. type-b.patch
          2 kB

          Issue Links

            Activity

              People

              • Assignee:
                bug zilla Bug Zilla
                Reporter:
                Smiley Giannis Adamopoulos
              • Votes:
                4 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: