Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-13837

ReactOS r75971 crashes on boot after installation of Video Driver

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Untriaged
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: Drivers
    • Labels:
      None

      Description

      ReactOS r75971 crashes on boot on real Hardware after installation of Video Driver for VIA Tech VT8361/VT8601 Graphics Controller
      DriverVer=09/24/2002, 6.13.10.3137

      Mother board model Gigabyte GA-6VEML (F7 bios revision)
      256 mb of RAM and 8 mb of shared video memory

      (win32ss/user/ntuser/class.c:2335) err: SYSTEMCUR(ARROW) == NULL, should not hap                                                                                        pen!!
      (win32ss/user/ntuser/class.c:2335) err: SYSTEMCUR(ARROW) == NULL, should not hap                                                                                        pen!!
      (win32ss/user/ntuser/class.c:2335) err: SYSTEMCUR(ARROW) == NULL, should not hap                                                                                        pen!!
      (win32ss/user/ntuser/class.c:2335) err: SYSTEMCUR(ARROW) == NULL, should not hap                                                                                        pen!!
      (win32ss/user/ntuser/class.c:2335) err: SYSTEMCUR(ARROW) == NULL, should not hap                                                                                        pen!!
      (win32ss/user/ntuser/class.c:2335) err: SYSTEMCUR(ARROW) == NULL, should not hap                                                                                        pen!!
      (win32ss/user/ntuser/winsta.c:226) err: Invalid window station handle
      (win32ss/user/ntuser/clipboard.c:31) err: Cannot open winsta
      (win32ss/user/ntuser/winsta.c:494) err: Initializing input window station
      (win32ss/user/ntuser/desktop.c:2422) err: Attempted to change thread desktop although the thread has windows!
      (ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\System32\kbdru.dll at F84AB000 with 5 pages
      (ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\System32\kbdus.dll at F8435000 with 5 pages
      (base/system/services/services.c:279) ScmApplyServiceAccountsHack()
      (base/system/services/services.c:148) ScmLogAccountsHack(LocalService, S-1-5-19)
      (ntoskrnl/config/cmcheck.c:25) CmCheckRegistry(0xFF6C30E8, 0) is UNIMPLEMENTED!
      (base/system/services/services.c:241) ScmLogAccountsHack(LocalService) returnedsuccess
      (base/system/services/services.c:148) ScmLogAccountsHack(NetworkService, S-1-5-20)
      (dll/win32/kernel32/client/loader.c:384) LoadLibraryExW(wlnotify.dll) failing with status c0000135
      (ntoskrnl/config/cmcheck.c:25) CmCheckRegistry(0xFF6BF3E8, 0) is UNIMPLEMENTED!
      (base/system/services/services.c:241) ScmLogAccountsHack(NetworkService) returned success
      (base/system/services/services.c:64) ScmLogEvent: RegisterEventSourceW failed 1722
      (base/system/services/services.c:64) ScmLogEvent: RegisterEventSourceW failed 1722
      (win32ss/gdi/eng/pdevobj.c:187) Failed to enable PDEV
      (win32ss/gdi/eng/pdevobj.c:419) Failed to enable PDEV!
      fixme:(dll/win32/rpcrt4/rpc_server.c:1716) (0x1000): stub
       
      Entered debugger on last-chance exception (Exception Code: 0xc0000005) (Page Fault)
      Memory at 0x7FFD7000 could not be read: Page not present.
      kdb:> bt
      Eip:
      <win32k.sys:1390b (win32ss/gdi/eng/pdevobj.c:134 (PDEVOBJ_vRelease))>
      Frames:
      <win32k.sys:13fd4 (win32ss/gdi/eng/pdevobj.c:420 (EngpCreatePDEV))>
      <win32k.sys:141ec (win32ss/gdi/eng/pdevobj.c:624 (EngpGetPDEV))>
      <win32k.sys:985f0 (win32ss/gdi/ntgdi/dclife.c:650 (GreOpenDCW))>
      <win32k.sys:993fb (win32ss/gdi/ntgdi/dclife.c:1041 (IntGdiCreateDC))>
      <win32k.sys:87b8d (win32ss/user/ntuser/winsta.c:251 (co_IntInitializeDesktopGraphics))>
      <win32k.sys:3d106 (win32ss/user/ntuser/guicheck.c:29 (co_AddGuiApp))>
      <win32k.sys:3d178 (win32ss/user/ntuser/guicheck.c:61 (co_IntGraphicsCheck))>
      <win32k.sys:77936 (win32ss/user/ntuser/windc.c:44 (DceCreateDisplayDC))>
      <win32k.sys:779d7 (win32ss/user/ntuser/windc.c:93 (DceAllocDCE))>
      <win32k.sys:78058 (win32ss/user/ntuser/windc.c:487 (UserGetDCEx))>
      <win32k.sys:78d32 (win32ss/user/ntuser/windc.c:986 (NtUserGetDCEx))>
      <win32k.sys:78e28 (win32ss/user/ntuser/windc.c:1017 (NtUserGetDC))>
      <NTOSKRNL.EXE:12a66e (ntoskrnl/include/internal/i386/ke.h:712 (KiSystemServiceHandler))>
      <NTOSKRNL.EXE:3da9 (:0 (KiFastCallEntry))>
      <ntdll.dll:cc25>
      <user32.dll:3e7d5>
      <user32.dll:41fd5>
      <msgina.dll:39cf>
      <kernel32.dll:1b30a>
      --- Press q to abort, any other key to continue ---
      <00000000>
      kdb:> cont
       
      *** Fatal System Error: 0x0000001e
                             (0xC0000005,0xF860290B,0xF837EA5C,0x00000000)
       
      Entered debugger on embedded INT3 at 0x0008:0x80945f34.
      kdb:>

        Attachments

        1. KPLE2KXP.INF
          7 kB
        2. r75986.txt
          18 kB
        3. set and boot log.txt
          85 kB

          Activity

            People

            • Assignee:
              bug zilla Bug Zilla
              Reporter:
              Jedi-to-be Jedi-to-be
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: