Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-14783

QMMP 0.11.1 does not longer play sound, but older QMMP 0.9.7 does

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: Sound
    • Labels:
      None

      Description

      Recently someone updated QMMP 0.9.7 to QMMP 0.11.1 in rapps-db.
      The newer version does not longer play any sound, but the old one does.

      Environment:
      -VBox 4.3.40 with working AC97 driver from rapps.
      -I double-checked sound to be working before and after that experiment, sysaudio did not "suck" in that experiment
      -ros 0.4.9-RC-35-g3eb03ef

      Reproduction steps
      -Install QMMP
      -add C:\ReactOS\media\ReactOS_Logon.wav into playlist
      -double-click that item in the playlist

      Expected result
      The sound is played

      Observed result
      No sound is played

      The new version QMMP 0.11.1, that can not play sound, logs:

      (../../drivers/wdm/audio/backpln/portcls/pin_wavecyclic.cpp:1228) CPortPinWaveCyclic::Init Status 0 PinId 0 Capture 0
      (../../drivers/wdm/audio/backpln/portcls/pin_wavecyclic.cpp:1304) Bits 16 Samples 44100 Channels 2 Tag 1 FrameSize 1764 CommonBufferSize 7056, CommonBuffer F6DC2000
      err:(../../dll/opengl/opengl32/wgl.c:740) Error: hdc is not a DC handle!
      (../../drivers/wdm/audio/legacy/wdmaud/control.c:161) Closing device 8000066C
      

      I double-clicked the file in the playlist multiple times, that's why you see the sequence repeated within QMMP0_11_1.log

      The old working version QMMP 0.9.7 logs while properly playing the sound:

      (../../drivers/wdm/audio/backpln/portcls/pin_wavecyclic.cpp:1228) CPortPinWaveCyclic::Init Status 0 PinId 0 Capture 0
      (../../drivers/wdm/audio/backpln/portcls/pin_wavecyclic.cpp:1304) Bits 16 Samples 44100 Channels 2 Tag 1 FrameSize 1764 CommonBufferSize 7056, CommonBuffer F6DC2000
      err:(../../dll/opengl/opengl32/wgl.c:740) Error: hdc is not a DC handle!
      err:(../../dll/opengl/opengl32/wgl.c:740) Error: hdc is not a DC handle!
      err:(../../dll/opengl/opengl32/wgl.c:740) Error: hdc is not a DC handle!
      err:(../../dll/opengl/opengl32/wgl.c:740) Error: hdc is not a DC handle!
      (../../drivers/wdm/audio/legacy/wdmaud/control.c:161) Closing device 80000604
      

      Different builds of that app can be found here: http://qmmp.ylsoftware.com/files/windows/

        Attachments

          Activity

            People

            • Assignee:
              bug zilla Bug Zilla
              Reporter:
              reactosfanboy reactosfanboy
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: