Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-14931

UNIATA - Unable to detect HDD on SiS 180 SATA controller

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Untriaged
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: Drivers
    • Labels:
      None

      Description

      Hello!

       

      I am having trouble using the Universal ATA driver (UNIATA) on the following system:

       

      Elitegroup ECS KV2 Extreme - Socket 939 Motherboard

      AMD Athlon 64 3000 CPU

      VIA K8T800 Pro Northbridge

      VIA VT8237 Southbridge

      SiS 180 SATA RAID Controller (No RAID configured)

       

      My goal is to get Microsoft Windows NT 4.0 SP6 and ReactOS working on this system.

      The official SiS driver works flawlessly on Windows 98 SE and Windows XP 32-Bit. (Tried out other HDDs as well, but same result.) The onboard VIA SATA controller and the second onboard IDE-channel have been disabled in the BIOS. The onboard IDE is only used for the DVD-drive (legacy CD-Audio in MS-DOS).

       

      When using the UNIATA v0.46e5 on Windows NT 4.0 SP6, it does not detect any HDDs. The system bluescreens with a friendly 0x7B "INACCESSIBLE_BOOT_DEVICE"-type BSOD. I did initially setup the installation using VMware and confirmed the UNIATA-driver to be working just fine there. (Booting off the virtual IDE drive, etc.). All other (RAID/IDE) controller drivers have previously been uninstalled, as recommended in the README-file. NT 4.0 SP6 works just fine using an IDE drive on the same system, utilizing the builtin Microsoft IDE Bus driver.

       

      To troubleshoot this, I tried out the most recent version of ReactOS (0.4.9) and found out that the HDD is not getting detected there either. The installer does not detect it and aborts the installation.

      I can confirm that the driver is loaded when using the Live CD:

      It is listed in the device manager as "Generic RAID IDE Controller", featuring the PCI-ID 1039:0180. (See attached screenshots).

      However, the "atactl"-utility does not find any drives. Re-scanning the controller using its experimental flags did not make any difference either (See attached screenshots)

       

      Since I would really like to run both operating systems on this machine (every single component should otherwise be downward-compatible to Windows 95 and Windows NT 4.0), I am asking for your help to get this driver working properly. I hope I provided you with sufficient information to give you a rough idea of what the problem might be, and I would gladly assist you with gathering more information if needed. (If you are interested in fixing this, that is.)

      I also included various (potentially useful) outputs of "lspci" from a Linux system.

       

      OT: Thank you all a lot for your work, Alter and the ReactOS-team.

      I actually haven't used ReactOS in eight years and I am impressed with how far you all have come.

       

      Have a great day!

       

      Best regards,

      Alexander Schreiber (schreiberstein)

       

       

        Attachments

        1. dmesg.txt
          39 kB
        2. IMG_5384.JPG
          IMG_5384.JPG
          2.48 MB
        3. IMG_5386.JPG
          IMG_5386.JPG
          2.40 MB
        4. IMG_5387.JPG
          IMG_5387.JPG
          2.41 MB
        5. lspci.txt
          2 kB
        6. lspci-nv.txt
          13 kB
        7. lspci-v.txt
          6 kB
        8. lsscsi.txt
          0.2 kB
        9. SISRAID-DeviceManager-XP-Offical-Driver.txt
          0.8 kB

          Activity

            People

            • Assignee:
              bug zilla Bug Zilla
              Reporter:
              schreiberstein schreiberstein
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: