Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-15774

ReactOS fails to boot at 2nd setup stage in Sun xVM VirtualBox 2.0.8

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Untriaged
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: NTCore
    • Environment:

      Sun xVM VirtualBox 2.0.8

      Description

      Tested with 0.4.12-dev-718-g8467d6e, both in host ReactOS and Win2k3, with the same VM settings, which are also attached. Win2k3 boots in this VM successfully, ROS - does not boot. So looks like it's not VBox problem. Only 1st setup stage completes without problems, but at 2nd stage appears an assetion visible on screenshots. Keyboard input also doesn't work in kdb, same as in host Win2k3 + guest ReactOS, so I can't type anything. Also I can't get debug log from that version of VBox since there is no "Redirection to file" option in COM ports settings. So I attached only screen debug output.

      Link to VirutalBox 2.0.8 installer: http://www.oldversion.com/windows/download/virtualbox-2-0-8

      P.S.: Please note that VMs in VBox on ROS are aviable only until closing and next launching VBox Manager. After that, they will become unavailable. So don't close Manager before test finishing.

        Attachments

        1. ros-in-ros.png
          ros-in-ros.png
          308 kB
        2. ros-in-ros-ok.png
          ros-in-ros-ok.png
          68 kB
        3. ros-in-w2k3.png
          ros-in-w2k3.png
          313 kB
        4. vm-settings.png
          vm-settings.png
          14 kB
        5. w2k3-in-ros-ga.png
          w2k3-in-ros-ga.png
          48 kB

          Activity

            People

            • Assignee:
              bug zilla Bug Zilla
              Reporter:
              Oleg Dubinskij Oleg Dubinskiy
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: