Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-15966

FTP disconnects after get operation, prints random text

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Untriaged
    • Priority: Minor
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      I set up an FTP server on my windows 7 machine using the built in IIS based utility, and set it up for anonymous authentication; with the goal of retrieving "video.exe".

      img1.bmp shows the result and reproduction steps, it disconnects after trying to get the file and then upon reconnecting spits the garbage characters you can see in the screenshot. The more commands you run, the more wacky characters you get. This doesn't occur with the windows based FTP utility. "debug04222019at190718.txt" is the debug log from this but I didn't notice any useful output when I was running these commands. I tried this on a different system as well, with the same result. This could potentially be two issues in one if the disconnect portion and random text printing portion aren't linked. I can modify this into two issues upon request.

      ReactOS Build: 20190421-0.4.13-dev-74-g24647a2

      Computer: Dell Precision T5400 (BIOS Rev. A10)

      CPU: 4 Core Xeon 5400 Series

      RAM: 8GB of matched, known good DDR2 RAM

      Storage: 2x 160GB WD1600AAJS HDDs

      Network: Broadcom BCM5754 Integrated

      GPU: Nvidia Geforce 9600

        Attachments

          Activity

            People

            • Assignee:
              bug zilla Bug Zilla
              Reporter:
              crandom41 crandom41
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: