Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-16461

Boot hangs when USB is enabled

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: Drivers: USB
    • Labels:

      Description

      In releases prior 0.4.13 I only had a issue booting when a mouse was attached to an USB port during the ROS boot process (symptoms as in CORE-12900).

      In ROS 0.4.13 RC-17 (with usbhub_new), however the issue is more severe and possibly has another root cause.

      If, I do a cold boot (in contrast to a restart) with USB interfaces enabled (with or w/o mouse), ROS will get stuck. This is reproducible.
      I only doesn't happen if the initial (cold) boot is done with USB interfaces disabled in BIOS. During a restart I can enable them in BIOS and booting will work as well - even with mouse attached.

      I have attached a screen debug log until the point where the boot process stops - both with and without mouse attached. (They are different, to my surprise.) Hope this helps.

        Attachments

          Activity

            People

            • Assignee:
              bug zilla Bug Zilla
              Reporter:
              matthiasbasler Matthias Basler
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: