Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-16661

Unhandled exception when trying to connect to WEP network on Asus-F5R notebook

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Untriaged
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: Drivers: Other, Networking
    • Labels:
    • Environment:

      Asus-F5R notebook PC.

      Description

      ReactOS 0.4.14-dev-844-gea35843 tested on Asus-F5R notebook PC.

      Notebook characteristics: https://www.comx-computers.co.za/laptop-specification-sheet.php?laptop=17223.

      Wireless network adapter is Atheros AR5006EG. The following driver has been used from the official Asus website: https://dlcdnets.asus.com/pub/ASUS/nb/F7E/WLAN_Azurewave_GE-780_XP.zip.
      It installs successfully, and after reboot, networking works ("wlanconf -s" shows all available WEP networks). But when trying to connect to my WEP WiFi network, after typing "wlanconf -c SSID -w xxxxxxxxxxxxx", nothing appears in the command prompt, but in the log I see the following unandled exception in ndisuio driver:

      (drivers/network/ndisuio/ioctl.c:203) Final request status: 0x0 (10)
      Unhandled exception
      ExceptionCode:    c0000005
      Faulting Address:  d0100fa
      CS:EIP 1b:7c947612
      DS 23 ES 23 FS 3b GS 0
      EAX: 0d010102   EBX: 0000001c   ECX: 002301cc
      EDX: 00000006   EBP: 0022f9d0   ESI: 00230000   ESP: 0022f950
      EDI: 0d0100fa   EFLAGS: 00010287
      (drivers/network/ndisuio/createclose.c:49) Closing file object 0xffab61f0
      (drivers/network/ndisuio/createclose.c:56) Removing binding to adapter \Device\{9402ee4b-fc79-40e3-b578-dcdcf423635f}
      

      And still no networking.
      Also in Device Manager, it the adapter properties, "Radio" is always "Off" and it fails to change after setting it to "On" and closing the device properties, although in registry it already is 1 ("On"). It is enabled on the notebook too (LED indicator is active).

      Full debug.log is also attached.

      UPD: When I creating this ticket, there also happened mystical Winlogon crash, which caused fatal system error, after closing the crash messagebox. But I hope that it is unrelated to the main problem.

        Attachments

        1. debug.log
          210 kB
        2. firstchance.log
          86 kB
        3. firstchance-new.log
          92 kB
        4. IMG_20200126_210813.jpg
          IMG_20200126_210813.jpg
          1.35 MB

          Activity

            People

            • Assignee:
              bug zilla Bug Zilla
              Reporter:
              Oleg Dubinskij Oleg Dubinskiy
            • Votes:
              3 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: