Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-17052

usbport assertion inside USBPORT_InitializeDevice when some devices are connected

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reopened
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: Drivers: USB
    • Labels:

      Description

      ROS version: ReactOS 0.4.15-dev (Build 20201021-0.4.15-dev-1174-gde8d156) (Commit e8d156e2cfa43e07c7ae07176e52b90ad7b5a95)

      I have done three trials with the USB Logitech Wireless Combo MK235. They're: CU0010 2.4GHz Transceiver, M170 Logitech mouse and K235 Keyboard.

      • In an Advent 4211 (USB ports 2.0) Motherboard: MS-N0111.
        Everything works.
        Debug log: Advent k235.log
      • In Dell Optiplex 3010 (USB ports 2.0). Motherboard: 42P49
        Failed.
        I can't get any debug log because the system freezes totally. I can't enter to the Screen debug mode at all when everything brokes.
        The only thing I can get is, after the Freeloader, this ending from the Screen debug mode:

        The other lines happens too fast to my screen to show it correctly and my camera too slow to catch it. And I can't go through the pages, because the keyboard freeze doesn't allow me to press any key.
        And the list that appears when I'm trying to do the same debug.log and the system freezes, recovered out of ReactOS. I guess is a little before the issue happened:
        Dell Optiplex 3010 - Logitech.log

      [Boot]

      Also:
      (Debug log of the system with other keyboard Logitech K120 running) Logitech k120.log

      ReactOS version:

      1. Tried to use it in the BootCD. It hangs at the "first stage of finding devices, no Screen debug".

      2. Tried to use it after the installation, in the boot process. Happens what I said before, after the freeze no keyboard input possible.

      3. Tried to use it inserting it when the system is running. No debug mode can be activated.

      In all the cases. The system freezes. I haven't tried on LiveCD, but surely it have same behavior.

      Weirdly, the combo works ok always in the Freeloader.

       

        Attachments

        1. Advent k235.log
          101 kB
        2. Dell Optiplex 3010 - Logitech.log
          105 kB
        3. Error Logitech k235+m170.png
          Error Logitech k235+m170.png
          1.01 MB
        4. k223 VirtualBox.log
          42 kB
        5. k235 VirtualBox.log
          42 kB
        6. Logitech k120.log
          153 kB

          Activity

            People

            • Assignee:
              bug zilla Bug Zilla
              Reporter:
              julenuri julenuri
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: