Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-17536

Inserting USB drive seems to kills "My Computer"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Untriaged
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      Inserted a USB pen drive and expected the OS to mount the volume for read and write.

       

      Freshly installed copy of the latest 2021-04-05 nightly for build 0.4.15-x86-dev on an IBM Thinkpad T43 laptop.  Install worked fine, however after the initial 2 boots and getting past the hardware driver prompts, it lands nicely on a working desktop.  However when I insert a USB drive (containing SDI) it seems to kill "My Computer".  Firstly it doesn't auto-refresh to show that the volume was successfully mounted (suspect this is the root cause right here), but secondly with explorer.exe in an unresponsive state the whole OS turns to fudge.  I can get Task Manager up, but it fails to kill explorer.exe (in Windows this causes explorer.exe to auto-restart).  Soft-rebooting also doesn't work (via the menus)... hence the only option that remains seems to be the old hold-the-power-button-down trick.

       

      I tried a second time after a reboot.  This time when inserting the USB drive it doesn't seem to even attempt to mount the drive, and My Computer appears to continue to function, albeit showing only C: and D: (the CD-ROM).  I then tried to soft-reboot, and received a BSOD with the following stop code:

          • STOP: 0x0000001E (0x80000003,0x805824E2,0xF7146724,0x00000000)
          • ntoskrnl.exe - Address 805824E2 base at 80400000, DateStamp 606ac8dd
            Kernal Debugger: Serial port not found!

       

      Hopefully this helps someone.  Happy to assist further if you need me to try anything further.  Thanks.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              irwazr irwazr
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: