Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-18227

ReactOS in Parallels Desktop 13 VM: "Failed to open txtsetup.sif"



    • Bug
    • Resolution: Unresolved
    • Major
    • None
    • Bootloader


      ReactOS 0.4.15-4853 refuses to start from the bootcd ISO, and only displays the message "Failed to open txtsetup.sif". In fact, I haven't been able to get any ReactOS bootcd ISO to work since 0.4.13 build 1080.


      The last working version for me was bootcd-0.4.13-dev-1080-g4843c1a-x86-gcc-lin-dbg.iso. That version successfully runs the ISO / CD installer fully & completes installation.

      When I run the ISO of the very next version (bootcd-0.4.13-dev-1081-geeff926-x86-gcc-lin-dbg.iso), all I get is a black screen. I don't even get to the "Failed to open txtsetup.sif" error message. Apparently the change in 0.4.13-1081 was this commit:

      [FREELDR] Limit the usage of DiskStopFloppyMotor() in hardware/platform-specific code.https://github.com/reactos/reactos/commit/eeff926ede1b2109bb0e129a960b74f3261cf2f1
      I am able to workaround this in 0.4.13-1081 if I completely remove the Floppy Drive device from the VM (ie as if the machine didn't have a floppy drive attached at all). In that case, the ISO successfully runs & I can install ReactOS to the VM's hard drive. Unfortunately this workaround only works up to 0.4.13 build 1152. And if I try adding the Floppy Drive back to the VM after installing & boot from the hard drive, ReactOS booting hangs and I get only this one line in the serial port debug log:

      (/srv/buildbot/worker_data/Build_GCCLin_x86/build/boot/freeldr/freeldr/arch/i386/hwpci.c:73) err: No valid routing table found!


      The first ISO version to display the "Failed to open txtsetup.sif" error and prevent all installation is bootcd-0.4.13-dev-1156-ge18e7b1-x86-gcc-lin-dbg.iso. The bootcd does not progress beyond it, whether or not the VM has a virtual Floppy Drive. This version emits just a single line to the serial port debug log when the error appears:

      (/srv/buildbot/worker_data/Build_GCCLin_x86_Release/build/boot/freeldr/freeldr/arch/i386/hwdisk.c:133) err: SectorSize (2048) Unable to render embedded object: File (= Geometry.BytesPerSector (512), expect problems) not found.

      As 0.4.13 dev 1156 was built on 18 September 2019, I believe the above diagnostic message was first introduced in this commit:

      [FREELDR] Addendum / actual fix for ef76709

      I get this same behaviour from every newer version of ReactOS I've tried, though I can't get any logging at all out of the serial port from the very latest 0.4.15 build 4853.


      Virtual Machine is setup as:

      • 1 CPU
      • 1024MB RAM
      • HDD: 64GB expanding disk (also tried 10GB fixed size disk)
      • 1 Floppy Drive emulated (but also tried without)
      • Selected VM OS Type = Windows Server 2003

      Parallels Desktop 13 details / host machine are:

      • Parallels Desktop 13.3.2
      • MacBook Pro mid-2012
      • 2.9GHz Intel Core i7 (Ivy Bridge I7-3520M)
      • 16GB RAM

      For comparison, I have attached a debug logfile from 0.4.13 build 1080 where everything is working, and from 0.4.13 build 1081 when it first breaks for me. I am unable to generate any logging at all from 0.4.15 build 4853 via the serial port, even with Enable Boot Logging and Debugging Mode enabled.

      And just for reference, this is the bug I mentioned in the following Twitter thread to
      Stas'M: https://twitter.com/syneryder/status/1539533162941796352




            Unassigned Unassigned
            SyneRyder SyneRyder
            1 Vote for this issue
            1 Start watching this issue