Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-12992

Virtual PC 2004 SP1: "VM Additions" doesn't fully install

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Untriaged
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Virtual PC 2004 SP1 (5.3.582.27)

      Description

      bootcd-74232-dbg.iso

      From a user p-o-v,

      • Install runs fine. (Files copied to C:\ReactOS\VMADD.)
      • Then, reboot too. (Not asked to, but it seems needed.)
        • NB: Before reboot, I tried to manually start the 2 services, but both failed.
      • VPC "VM Properties" correctly reports "Windows Server 2003 + v13.306".
      • Clock integration works. Clipboard integration too. Shared Folder too.
      • But, compared to Windows XP Pro:
        • no "VM Additions PC/AT Enhanced PS/2 Keyboard" driver.
        • no "VM Additions PS/2 Port Mouse" driver. (No mouse integration.)
        • no "VM Additions S3 Trio32/64" driver.

      From a ROS-dev p-o-v,

      Install debug.log

      ...
      (dll/win32/kernel32/client/loader.c:384) LoadLibraryExW(C:\ReactOS\Microsoft.NET\Framework\v4.0.30319\fusion.dll) failing with status c0000135
      ...
      (dll/win32/kernel32/client/loader.c:384) LoadLibraryExW(C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\{F7D2F453-B593-4875-9635-9B79FD77A81C}\_isuser.dll) failing with status c0000135
      ...
      (dll/win32/kernel32/client/loader.c:384) LoadLibraryExW(C:\ReactOS\Microsoft.NET\Framework\v4.0.30319\fusion.dll) failing with status c0000135
      ...
      err:(dll/win32/ole32/rpc.c:819) called from wrong apartment, should have been 0x37000000374
      err:(dll/win32/oleaut32/tmarshal.c:1610) RpcChannelBuffer SendReceive failed, 8001010e
      ...
      err:(dll/win32/ole32/marshal.c:1890) IMarshal::ReleaseMarshalData failed with error 0x8001011d
      (ntoskrnl/ex/sysinfo.c:825) Process FFB54D10 (MSIEXEC.EXE:000002FC) is a zombie
      ...


      NB:
      .NET Framework v4.0 is actually missing by default.
      Installing it first does not help (enough).

      PS:
      This installation works fine on Windows XP Pro. I don't know about W. S. 2003.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                bug zilla Bug Zilla
                Reporter:
                Serge Gautherie Serge Gautherie
              • Votes:
                4 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: