Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-15332

XEBRA Version 18/10/27 plays a game very slowly

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      ReactOS Version: 0.4.11-dev-648
      Download URL: http://drhell.web.fc2.com/ps1/xebra181027.zip

      When I try to play a game via it, the sound and video (which only shows when checking the Use OpenGL checkbox in the Video Output dialog box accessible via the menu item in the View Menu, just installing DirectX 9 and enabling 2D+3D hardware acceleration doesn't get it to display) is lagging because it is using 70-100% of the CPU. A debug log is attached.

      EDIT: I replaced the XEBRA.SIM file in its main directory with one I found on a reddit thread which has fixed most of the lag. I also replaced the portcls.sys that ReactOS uses with the one provided by Windows Server 2003 SP1. I have attached the XEBRA.SIM that is being mentioned.

        Attachments

        1. rosdbg_04190600.log
          151 kB
          Zero3K
        2. XEBRA.SIM
          0.2 kB
          Zero3K

          Issue Links

            Activity

              People

              • Assignee:
                bug zilla Bug Zilla
                Reporter:
                Zero3K Zero3K
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: