Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-17398

Unrecognized devices after the new storage stack

    XMLWordPrintable

    Details

      Description

      It started to happen somewhen during 0.4.15-dev'ing.

      Since the new storage stack we now have more unrecognized devices in the device manager.

      (base/services/umpnpmgr/install.c:112) Installing: Root\UNIATA\0000
      (base/services/umpnpmgr/install.c:112) Installing: Root\UNIATA\0001
      (base/services/umpnpmgr/install.c:112) Installing: SCSI\Net&Ven_UNIATA__&Prod_Management_Port_&Rev_47a_\1&18964f0b&100
      (dll/win32/syssetup/classinst.c:120) Failed to read the ClassGUID! (Error 2)
      err:(dll/win32/newdev/newdev.c:1006) DevInstallW failed with error 2
      (base/services/umpnpmgr/install.c:226) InstallDevice failed for DeviceInstance 'SCSI\Net&Ven_UNIATA__&Prod_Management_Port_&Rev_47a_\1&18964f0b&100'
      (base/services/umpnpmgr/install.c:112) Installing: SCSI\Net&Ven_UNIATA__&Prod_Management_Port_&Rev_47a_\1&18d7e4a&100
      (dll/win32/syssetup/classinst.c:120) Failed to read the ClassGUID! (Error 2)
      err:(dll/win32/newdev/newdev.c:1006) DevInstallW failed with error 2
      (base/services/umpnpmgr/install.c:226) InstallDevice failed for DeviceInstance 'SCSI\Net&Ven_UNIATA__&Prod_Management_Port_&Rev_47a_\1&18d7e4a&100'
      

      Root\UNIATA\0000 is probably the same or similar problem as CORE-17212.

      UNIATA Management Port problem seems different, related to the ClassGUID, but it's not clear why it's a problem. It uses standard system devices class {4D36E97D-E325-11CE-BFC1-08002BE10318}.

      Also there is separate problem with partition devices, they are not showed in device manager, but the user-mode plug-and-play manager still shows a "Unknown device" prompt for each of these.

      (base/services/umpnpmgr/install.c:112) Installing: STORAGE\Partition\Sbb3f07f7_O100000_L4ff876400
      err:(dll/win32/newdev/newdev.c:1006) DevInstallW failed with error 259
      (base/services/umpnpmgr/install.c:226) InstallDevice failed for DeviceInstance 'STORAGE\Partition\Sbb3f07f7_O100000_L4ff876400'
      

      Tested on 0.4.15-dev-1428-gda1f4ed6af.

      Debug log: 0.4.15-dev-1428-gda1f4ed6af-devices.log

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                extravert34 extravert34
                Reporter:
                binarymaster Stas'M
              • Votes:
                5 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: