Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-18238

[RealHW] Realtek AC97 audio drivers installs, but won't open the mixer.



    • Bug
    • Resolution: Unresolved
    • Major
    • None
    • None


      Environment: Real hardware, https://www.gigabyte.com/mx/Motherboard/GA-7VT600-L-rev-1x/sp#sp

      Hardware: Realtek ALC655 AC97 codec Chip (PCI\VEN_1106&DEV_3059&SUBSYS_A0021458).
      Under ReactOS is reported as:

      00:11.5 Multimedia audio controller [0401]: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller [1106:3059] (rev 60)
          Subsystem: GA-7VAX Onboard Audio (Realtek ALC650) [1458:a002]
          Flags: medium devsel, latency 0, IRQ 11
          I/O ports at e400 [size=256]
          Device is using IRQ 11! ISA Cards using that IRQ may fail!

      Drivers: https://download1.gigabyte.com/Files/Driver/motherboard_driver_audio_realtek_whql.exe?v=5fa8a5bf844487c219c28e1ba7c3afa7
      ROS ver: 0.4.15-dev-4872-g8a3db97-x86-gcc
      I tried to install the drivers of this old board, with the installer or manually. In both situations, the system says me that some ports are not working. I see in the log some interactions and attempts to start the audio service, and some ports interacting, but the audio and the mixer are not working. It neither works trying to use the legacy options.

      Screenshot: Noname.png

      Log: This is the log installing the drivers available in the link above Realtek audio pnp bug.log. If I change the portcls.sys with the XP one after the installation, the driver appears "succesfully installed" in the devmgr, but in fact it still not working.


        1. Realtek audio pnp bug.log
          137 kB
        2. Noname.png
          38 kB
        3. fe777bb - Full debug + Portcls.log
          2.00 MB
        4. fe777bb - Full debug.log
          3.05 MB
        5. fe777bb - common debug.log
          305 kB
        6. fe777bb - common debug. + msp.log
          265 kB
        7. 2ed132e-fullreport + msp.log
          2.40 MB
        8. 2ed132e-fullreport.log
          2.96 MB
        9. 2ed132e - common debug + msp.log
          431 kB
        10. 2ed132e-Common-Debug.log
          308 kB

        Issue Links



              Unassigned Unassigned
              julenuri julenuri
              0 Vote for this issue
              1 Start watching this issue