Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-7968

ROS won't install from BootCD neither run from LiveCD on Lenovo T400

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Incomplete
    • Fix Version/s: None
    • Component/s: Drivers, USB
    • Labels:
      None
    • Environment:

      Lenovo T400 + docking station (Advanced Mini Dock)

      Description

      I can't get ROS to run on the Thinkpad T400 notebook.
      There was a single NTFS partition with Win7 on the notebook before I started.

      USB bootcd won't get into usetup, CD bootcd gets into usetup, but fails to copy any files onto the freshly formatted partition.
      I tried debugging over the serial cable, but Putty got nothing. Z98 suggests the issue may be in PCI-to-PCI bridge and is not sure "if our PCI driver is capable of actually enumerating and detecting devices down-bridge". The serial port is only present on the dock station. It is I/O-port based (not MMIO-interface based).

      Thus LiveCD remains the only source of information for now.

      I also attach full system report from HWiNFO32 (text and HTML, contents identical) generated on the former Win7 installation.

      Initial results are moved here:
      r62417.
      LiveCD results: LiveUSB upon NTFS HDD partition (pictures 6013 and 6014), LiveCD upon NTFS HDD partition (6105) and LiveCD upon FAT32 HDD (6137 and 6138) partition each fail, although differently. "Log" photos including backtrace (where the system allowed me to type 'bt') are attached.

        Attachments

        1. SAM_6013_liveusb.JPG
          SAM_6013_liveusb.JPG
          321 kB
        2. SAM_6014_liveusb.JPG
          SAM_6014_liveusb.JPG
          313 kB
        3. SAM_6105_livecd.JPG
          SAM_6105_livecd.JPG
          770 kB
        4. SAM_6137_livecd.JPG
          SAM_6137_livecd.JPG
          375 kB
        5. SAM_6138_livecd.JPG
          SAM_6138_livecd.JPG
          161 kB
        6. SAM_6156_preinstalled.JPG
          SAM_6156_preinstalled.JPG
          273 kB
        7. SAM_6158_preinstalled.JPG
          SAM_6158_preinstalled.JPG
          329 kB
        8. SAM_6160_preinstalled.JPG
          SAM_6160_preinstalled.JPG
          351 kB
        9. SAM_6161_preinstalled.JPG
          SAM_6161_preinstalled.JPG
          322 kB
        10. SAM_7701_t400live_r63249.JPG
          SAM_7701_t400live_r63249.JPG
          171 kB
        11. SAM_7702_t400live_r63249.JPG
          SAM_7702_t400live_r63249.JPG
          154 kB
        12. SAM_7707_t400live_r63249.JPG
          SAM_7707_t400live_r63249.JPG
          86 kB
        13. T400.HTM
          143 kB
        14. T400.TXT
          114 kB

          Issue Links

            Activity

              People

              • Assignee:
                bug zilla Bug Zilla
                Reporter:
                Black_Fox Black_Fox
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: