Uploaded image for project: 'ReactOS Test Suite'
  1. ReactOS Test Suite
  2. ROSTESTS-264

[Windows XP/S03/Vista] "kmtest_ CcCopyRead" seems to "break" its (sub-)service

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: 0.4.9
    • Component/s: ReactOS Tests
    • Labels:
      None
    • Environment:

      *Virtual PC 2004 SP1 (5.3.582.27) + Windows XP.
      *Windows Virtual PC + Windows Server 2003 SP2.
      *Wine Test Bot: wxppro, w2003std, wvista.

      Description

      I used (13) kmtest files from bootcdregtest-74451.iso.

      > kmtest_ CcCopyRead
      CcCopyRead: 124 tests executed (0 marked as todo, 0 failures), 0 skipped.
       
      > kmtest_ stop
      > kmtest_ delete
       
      > kmtest_ create
      > kmtest_ start
      /srv/buildbot/Build_GCCLin_x86/build/reactos/modules/rostests/kmtests/kmtest/service.c:144: error 0x00000002: The system cannot find the file specified.

      Once in this state, trying to run any other kmtest will give the same error.

      NB:
      "All" other tests which use a sub-service do not have this issue.

      Virtual PC 2004 SP1 (5.3.582.27) + bootcdregtest-74451.iso : no issue.

      NB:
      It could also be interesting to find out why this test seems not to break (unexpectedly?) on ROS (KVM/VBox)...

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ThFabba ThFabba
                Reporter:
                Serge Gautherie Serge Gautherie
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: