Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-14351

2018-02-17 we broke compatibility to old rapps (we should condense planned compatibility breakers into a short timeframe to limit to a single compat-gap)

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: 0.4.8
    • Component/s: None
    • Labels:
      None

      Description

      2018-02-17 we changed our server infrastructure (certificate pinning & co).
      *This will make all rapps versions of earlier reactOS builds incapable to ever update their database again.
      The older rapps binary needs to be replaced with a newer compatible one in case you still intend to use older reactOS builds!*

      I have been told that this step is inevitable and that we can not preserve the compatibility. The devs were clear about that.

      The commit that allows newer binaries to be compatible to the infrastructure again was
      0.4.9-dev-20-gb56193a
      ----------
      Disclaimer is over,
      the request of this ticket is: Let's at least try to reduce to a single compatibility gap then and let's try to changes we think are necessary soon and that would break compatiblity as well switch from cab to zip at the same time (as sanchaez proposed multiple times already). We could then eliminate the poor cab-code in rapps that leads to other issues. We should try to implement those transitions within the next month if possible. (transition cab to zip is not necessary necessarily)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Colin Finck Colin Finck
                Reporter:
                reactosfanboy reactosfanboy
              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: