Uploaded image for project: 'Core ReactOS'
  1. Core ReactOS
  2. CORE-17566

"No GRAPHICS_DEVICE found" for intel 82810 video chip

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Untriaged
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      This is essentially the same bug as CORE-8444. After installing ROS on a eMachines eTower 500id, it boots straight to a blue screen of death with the error No GRAPHICS_DEVICE found. The graphics card is integrated into the motherboard in an intel 82810 Graphics and Memory Controller Hub (GMCH) chip. This is the relevant motherboard manual page:
      https://mbmanuals.retropc.se/manuals/125/Anaheim2.pdf#page=4
      This appears to be the driver for it:
      https://downloadcenter.intel.com/download/29363/Intel-815-and-810-Chipset-Family-Graphics-Driver-exe-
      I just tested with this version of ROS:
      reactos-bootcd-0.4.15-dev-2502-g9f3ed60-x86-gcc-lin-dbg.iso
      I reach the boot menu but I don't reach the desktop.

      I'm not sure if this helps, but FWIW I've noticed that Puppy Linux is able to render a GUI desktop, while antiX and Tiny Core Linux are not.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                atariZen atariZen
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: